Turning off Lightroom’s GPU preferences even when crashing on startup.

Lightroom Issues Tips

By default Lightroom will have the GPU on, unless it encounters an error with the GPU. The GPU really needs to be good, or Lightroom will actually be slower to use. Sometimes you can have crashes on startup, even with the 6.01 update so here’s a way to turn off the GPU without opening Lightroom.

Restart your machine. This is essential (especially on Mac), so that the preferences are not stored in memory when we edit them-or they will just be overwritten. When I was working on this, I hadn’t, and everytime Lightroom reopened it would revert the settings back to before I’d saved.

Find the Lightroom preferences file. On Mac, hold down Option and then select Library (hidden without the Option key) from the Go menu. Open the Preferences folder and search for com.adobe.Lightroom6.plist. On PC go to C:\Users\[user name]\AppData\Roaming\Adobe\Lightroom\Preferences\Lightroom 6 Preferences.agprefs where [user name] is your login name.

Update: For Lightroom Classic CC 7, this is now com.adobe.LightroomClassicCC7.plist on Mac. On PC it’s probably something similar to Lightroom Classic CC 7.agprefs (Thanks to @tetsu on Twitter for confirming).

Open the file in a text editor. Don’t use Word, etc, use Text Edit or Notepad.

Search for

useAutoBahn

Now on the line below this, change true to false and save.

It should now look like this:

<key>useAutoBahn</key>
<false/>

Don’t copy and paste that, do the edit.

Now start Lightroom. The GPU will be off. Hopefully if the GPU is your crash issue, this should let you start Lightroom.

Note: I did read similar suggestion on the Adobe forums last week, but I couldn’t find it in search, so I manually went through the preferences file to find the right preference for the GPU. During testing I noticed the rewriting on Lightroom startup and remembered that the preferences are now stored in memory once read, hence testing with a restart.

27 thoughts on “Turning off Lightroom’s GPU preferences even when crashing on startup.

  1. Hi. I’m trying this fix for Lightroom 4 which is suddenly crashing on me when I try to import photos. I wasn’t able to locate once I opened the com.adobe.Llghtroom4.plist
    I searched for that as you suggested and also many iterations of that as well as searching for and can’t find the autobahn command
    Is it because LR 4 is too old?
    Any other suggestions to solve the crashing issue?
    I have an iMac and have never had any problem with Lightroom before.
    Thanks

    1. Lightroom 4 doesn’t use the GPU, so this isn’t a fix for that. Photo import is pretty CPU intensive with preview generation, so maybe do some kind of memory check to see if one of your RAM chips hasn’t gone bad. There’s a whole hosts of potential reasons for crashes. I had a drive kext file corrupt and it would causes random crashes until I eventually found a new version of the file and manually overwrote the corrupt one.

  2. Hi,
    I just bought the stand alone Lightroom V6 (Oct 2017) and have tried all options to upgrade, without success. Any suggestions please.

    Thanks for your article. I cannot find the <key entry though. Perhaps upgrading is the first step?

    Thanks
    Dayalan

  3. Worked for me too. Many, many thanks, I was tearing my hair out and with an LRPS assessment coming up in just three weeks.

  4. I have Textedit and can see te right file to edit autobahn but when I try to open it I only get blank not the lines of code. Any ideas please. Thanks.

  5. Thank you. I was having all sorts of problems with my gpu checkbox (crashing when unticking) you’re a life safer!

    Tom

  6. I have been having the same problem and am using a standalone version of LR6.
    I have tried the above but cannot find the file you name,
    I have gone into users file and after that come up with nothing related to Adobe.

  7. Thank you so much for this! I had tried everything and had just about given up. I did one more search and came across your blog. I tried it and it worked!

  8. Is there a way to search the text edit file for useAutoBahn? There are thousands of lines of code and I can’t find it. Spotlight yields no results.

  9. I had to recently do a complete reinstall on my PC. I’m a heavy LR user and this issue was bugging the hell out of me. With your fix, problem solved. Thanks for your effort. Much appreciated on being able to find a solution online.

  10. Thank you so much. I wasn’t having issues with Win 7, but once I upgraded to Win 10, LR6 was crashing constantly. After updating video drivers and still having issues, decided to just turn off GPU processing. Except LR would crash every time I tried to disable the option. This article was fantastic. Solved my problem

  11. Thank you so much for this post. I had been trying to solve the crashing problem for awhile now with no luck. I was getting very discouraged and I haven’t even been taking pictures lately because it’s been too frustrating to deal with the constant crashing. I would try to disable the GPU in lightroom but that would only cause it to freeze and crash. But this worked like a charm, thank you so much!

  12. Thank you so, so much for this post. I had been having huge problems with LR6 on my system and nothing seemed to fix it. Initially, it was mega slow and I put this down to the problem that LR6 was having with AMD drivers. Finally, AMD produced a driver it seemed to like and I thought that would solve the problems, only to have them become much, much worse. I could not deselect GPU as it froze every time I tried to deselect it. Thanks to your helpful post I have been able to stop it trying to load GPU on startup and now it is going better than at any time since install. Many thanks.

  13. I had to reformatted my hard drive and reinstall Lightroom but I lost the feature where it automatically jump to the next image as soon as you rate a picture. How do I get that back?

Leave a Reply to Gary Cancel reply

Your email address will not be published. Required fields are marked *