Metadata Plugin Schema got you down?

plugins SDK Uncategorized

The Lightroom SDK covers the basics of creating a Metadata Plugin quite well. Detailed examples and explanations abound. I got a basic plugin going quickly and then went on to add new features to it. Two things I noticed I could add to the fields were

searchable=true,
browsable=true,

So I added searchable=true and then restarted Lightroom. Yes I know I can just reload the plugin, but sometimes restarting can rule out silly issues that may arise. All was well, or was it?
When I enabled the plugin I got a message I simply did not understand. It referred to a change in schema, with an increment in field version number needed to correct it. I had no idea what to do.. I tried expanding the schemaVersion code section and incrementing the schemaVersion. No joy. In the end I rang John Beardsworth. We’d been chinwagging online about Lua and the SDK and I figured he might be able to direct me. He was. It was all quite simple really. Each field you create also needs to have a ‘version=x.x’ line, which must be incremented when you change the properties of the field.

Obviously I got this all sorted, because lots of you are downloading LRB Releases. No reflection on the SDK writers as versioning is mentioned in the SDK (page 55 to be precise). It’s marked as optional, but if you are making changes to the field, then you need to use it.

1 thought on “Metadata Plugin Schema got you down?

  1. Do you know if it’s possible to override IPTC fields like location, title or caption with this browsable feature to have access to it through the filter bar?

Leave a Reply

Your email address will not be published. Required fields are marked *